Running Plattformer Example on Mac

I managed to build the platform example, but on my mac it looks like I only see on quarter of the screen, due to the DPI of the system.

What’s the magic setting to scale the screen so I can actually use it?

It’s a bug in Castle Game Engine, it seems we miss scaling coordinates/sizes by some monitor-specific value on macOS.

It’s a bug on our side – we should fix it (most likely in castle-engine/src/window/castlewindow_cocoa.inc at master · castle-engine/castle-engine · GitHub ). I’m afraid there’s no setting on CGE side to make it right – we should just fix our code.

More information in recent thread Mac OS "Access Violation" - #7 by sophia , see my answer at the bottom – Mac OS "Access Violation" - #8 by michalis . I’m guessing this is the same problem reported. Have patience, I’ll get to fixing this :slight_smile: