Microsoft Visual C++ Runtime error in CGE 6.4 when working with X3D scenes

#1

Hello,

I am on old latop running Windows 7 64bit with Intel Pentium Dual-Core CPU T4400 processor with built-in Intel 4 Series Express Chipset Family. OpenGL version 2.1 (very old). But Blender v2.79 works fine with it.
And I on 32bit Lazarus v 1.8.4.
I understand this computer is not for 3D. But, anyway, In CGE 6.4 work most of examples. All UI examples work fine. zombie_fighter works fine. And view3dscene.exe may load simple models.
But when I load X3D from demo-models to view3dscene.exe or when I use my project the same as https://castle-engine.io/manual_load_3d.php using Scene.Load() I am getting the error message.

screenshot000023

Using Blender I create a simple model. Exported it to X3D and tried to load it with view3dscene or my project. The error message is the same as above.

Which version of Microsoft Visual C++ Runtime do you use to build CGE 6.4? Maybe I need to reinstall it.

0 Likes

#2

If I press Retry button it shows the message:
screenshot000024

0 Likes

#3

You should not need to install Microsoft Visual C++ Runtime.

Hm, this looks more like a bug inside OpenGL.

Can you try running view3dscene from the snapshots ( http://michalis.ii.uni.wroc.pl/view3dscene-snapshots/ ), and run it from the command-line with the parameter --debug-enable-fixed-function, like

cd view3dscene/
view3dscene.exe --debug-enable-fixed-function

See if you can open in this view3dscene the models without error.

1 Like

#4

I tried both 32bit view3dscene-3.18.0-win32-i386.zip and 64bit version view3dscene-3.18.0-win64-x86_64.zip
Both versions are working fine without any error messages.
I was able to open models like
\x3d\axis.x3d
\x3d\regular_labirynth.x3d
and I was able to open my models which I exported from Blender to x3d and I even tried to export it .3ds - it works fine.

What does it practically mean? I should use CGE 6.5?
BTW I tried another viewer - FreeWRL (https://sourceforge.net/projects/freewrl/)- it may open the models without any errors.

0 Likes

#5

You mean view3dscene from snapshots just worked, without the need --debug-enable-fixed-function?

Then yes, it means that the issue is fixed in Castle Game Engine 6.5:) View3dscene from snapshots is using CGE 6.5. You can get latest CGE from GitHub ( https://github.com/castle-engine/castle-engine/ ), or even download a snapshot (announced this weekend, https://castle-engine.io/wp/2019/03/31/engine-news-6-5-release-snapshots-improvements-to-editor-tcastlewindowbase-joysticks-and-more/ ) from https://github.com/castle-engine/castle-engine/releases/tag/v6.5-snapshot .

We most probably added the GPU you use to force using fixed-function pipeline (older, but more stable on old laptops).

0 Likes

#6

The first time I tried it with --debug-enable-fixed-function I wrote it did work well.
Now I tried both 32bit and 64bit version of the latest view3dscene without this parameter on demo-models and on my models. It works fine too without this parameter.
So I will try to install v6.5 snapshot and it will try to create to use it in my test project to load a simple X3D model.

0 Likes

#7

I downloaded and installed v6.5 snapshot from https://github.com/castle-engine/castle-engine/releases/tag/v6.5-snapshot
I tried to compile my project: it works fine - it loads correctly my X3D model. And I compiled several projects in castle_game_engine\examples. The projects run well. Thus I will start using the snapshot instead of version 6.4.

1 Like