CGE scrambled display after last update

After updating to the latest CGE I got a “scrambled” display.
Here are some pictures; looks if there is something wrong with the tool window layout or so.
I tried re-installing but got the same result.

After loading my gamestateplay interface:
(property window to the right is also missing).

After “restore default docking layout”:

Hm, it seems the new “docking” is activated for you, and it is quite broken by default.

I will check. I understand you didn’t click 'Window → Docking" ?

For now, click 'Window → Docking" (this will make it disabled) and restart editor.

Yes, unchecking the docking option works.

I’m looking at code, and I have no idea how it could have activated “by itself”. By default, this should be unchecked, i.e. “no docking” (things behave as before).

Testing confirms it, i.e. starting editor with empty config – starts in “no docking”.

Did you possibly enable “Window → Docking” yourself before?

( Note that there’s still a problem that default layout is not always good. But that’s a separate problem. The “Window → Docking” should be disabled by default, people have to enable it explicitly. )

Then I guess the docking was not disabled by default. I had deleted all old files but the config was still there. I just found it in appdata\local and it is:

<CONFIG ProjectForm_Top="-11" fpc_custom_path="F:\lazarus\fpc\3.2.2" ProjectForm_Left="-11" ProjectForm_Saved="True" ProjectForm_Width="3840" ProjectForm_Height="2066" ProjectForm_Docking="False" lazarus_custom_path="F:\lazarus" ProjectForm_DesignSaved="True" ProjectForm_WindowState="wsMaximized" ProjectForm_Design.PanelLeft.Width="457" ProjectForm_Design.PanelRight.Width="550" ProjectForm_PageControlBottom.Height="269">

Docking is set to false but this is after I unchecked and saved this option in CGE.
So after a new installation of latest CGE in the map “castle game engine” on starting I guess it reads the old config when it is present and finds no previous docking settings (as it is a new option in the latest CGE) but then CGE starts anyway with the docking selected.

But I checked on my end, and it’s not the case :slight_smile:

  • When there’s no ProjectForm_Docking="False" in the config file (like upgrading from previous CGE version) then the default is false.

  • I confirmed it with own test on Windows and Linux. Deleting the castle-editor.conf file and starting editor → results in docking = off.

Can yoy check n your end? Rename castle-editor.conf to something like castle-editor.conf.old temporarily, run editor, and observe whether docking is enabled.

Yes, then CGE starts up with docking option disabled.
As I have overwritten the old config (by starting the new CGE and then disabling Docking) I cannot compare how the config file looked before, but I know it started with docking enabled after I started CGE the first time after updating :slight_smile:

I just checked the upgrade path, and it worked OK for me.

On Windows, I took CGE version from right before docking was available (GIT commit ). Opened the editor, opened some project, and got a config file (without any ProjectForm_Docking value, attaching).

Then I upgraded to latest CGE editor, and it started without docking, correctly. As long as I don’t click “Window → Docking” menu option, it stays without docking. It adds ProjectForm_Docking="False" to the config file.

castle-editor-backup-before-docking.conf.txt (587 Bytes)

Thanks for sorting this out.
Well I don’t know why it didn’t work for me the first time I started CGE after updating, but nevermind, it works okay now.

Have you already found the bug in CGE that causes rotated transforms shooting out of the screen when they are moved while dragging the red arrow?

After testing docking more, I decided to hide this feature anyway for now. If you’re curious, the relevant issues are

For now, everyone interested in contributing/testing can enable it: create a file enable-docking.txt (with any contents, empty is OK) alongside your castle-editor.conf . On a typical Windows 10 installation, this will be


On a typical Linux installation, this will be


(I’ll annouce it soon in CGE news).

Not yet, that is next on TODO. Thank you for the testcase there!